As an anonymous user, you can only add new data. If you would like to also modify existing data, please create an account and indicate your languages on your user page.

Meta:Insect room/Archive/2009

From OmegaWiki
Jump to: navigation, search

Functionality broken ?[edit]

On Siebrand's user page there is a function that gets us the following message.. "Fatal error: Call to undefined function initializeObjectAttributeEditors() in /var/www/ow/extensions/Wikidata/OmegaWiki/Wikidata.php on line 84" This is from the NeedsTranslation functionality .. GerardM 07:26, 28 January 2008 (EST)

I don't know how it was in the past but this seems to have been superseeded by Special:NeedsTranslation. Malafaya 11:34, 16 February 2009 (EST)

Go button automatically convert to lowercase[edit]

For example, when we look for the German "Verstand" with uppercase with the box on the left, it goes to the Dutch "verstand" with lowercase. Kipcool 11:26, 29 July 2006 (CEST)

Posted on bugzilla [1]. Kipcool 14:01, 21 August 2006 (CEST)
When searching for God, the only hit is for the Swedish expression god at DefinedMeaning:good_(6038). The results doesn't include the English syntrans at DefinedMeaning:Vater_(5472) Gon-no-suke 02:24, 20 March 2007 (EDT)
Fixed earlier this year. --Kipcool 21:41, 9 October 2009 (UTC)

Expression:a[edit]

When I try to open the expression a, I get an error. I found this expression while searching the Czech language. Malafaya 12:33, 12 February 2007 (EST)

I also get an error when I search for "a" or click on a link to Expression:a even on the talk page Expression talk:a. The error message is "Fatal error: Call to a member function getAttributeValue() on a non-object in /usr/local/apache/htdocs/ow/extensions/Wikidata/OmegaWiki/OmegaWikiRecordSets.php on line 961". --Ortografix 15:00, 11 April 2007 (EDT)
The problem is still not fixed. --Ortografix 16:54, 23 January 2008 (EST) --Ortografix 23:55, 11 February 2009 (CET)
The query that is being executed (according to the error page) is "SELECT attribute_mid FROM uw_class_attributes WHERE object_id = AND uw_class_attributes.remove_transaction_id IS NULL " Note "object_id = AND" that is there is no value following =. --Sannab 09:20, 12 February 2009 (CET)
I have some more data. It seems to be related to this record somehow:
SELECT * FROM uw_option_attribute_options where option_id=413809;
which is marked as deleted. It looks like something should have been deleted too but is still hanging around. I can't seem to find what table could be pointing at this record. A DB diagram or at least a list of foreign keys would be really handy. Malafaya 17:12, 14 February 2009 (CET)
Almost Done Done I found the problem and solution. The solution is UPDATE uw_option_attribute_values set remove_transaction_id = 62833 where value_id=436009;.
This problem is related to the removal of a part of speech item for Portuguese ('contraction') unfortunately by myself (plain guilty!) some two years ago. This option had been previously assigned to one of the syntrans in a. By what I could find out, adding the removed option item again to lexical item class attributes doesn't solve the problem because it gets a option_attribute_option Id different from the one already in use in option_attribute_value. The solution is to mark it as deleted (above SQL statement).
So, the true issue it that when an option item is removed from an options list (i.e., such as removing 'noun' from 'lexical item' 's English 'part of speech' options list), all option values for that option item should be removed from syntranses.
Right now, I don't have access to OW database because it's in a temporary server to which I don't have access. I'll try to remember to get back to this next week, when everything should be back to normal. Thanks, Malafaya 23:40, 14 February 2009 (CET)
I searched the database for other possible cases: Expression:hospitalize and Expression:bachelorette are the other two cases with the same problem.
These are solved with UPDATE uw_option_attribute_values set remove_transaction_id = 52108 where value_id in (411856, 411852);. Malafaya 02:51, 15 February 2009 (CET)
Done Done. Fixed all 3 cases. Malafaya 10:04, 16 February 2009 (EST)

Changes in history that aren't changes[edit]

Sometimes when I edit an entry another field that I didn't change will show up as edited. As far as I can tell this happens mostly (or even exclusively) with English definitions from entries belonging to the GEMET collection. An example is DefinedMeaning:sound emission (3557). In the history you will see that I apparently "edited" the English definition, but I didn't, and the two versions are 100% identical. – McDutchie 08:55, 26 April 2009 (EDT)

I believe this is due to the imported GEMET data having an extra space at the end of the text. When editing, this space is trimmed automatically upon page save, hence showing up as edited. Malafaya 15:50, 30 April 2009 (EDT)

The collapse symbol is not updated for languages[edit]

I found this one on the history page of glass. It's just a cosmetic bug that regards to the plus or minus character at the left of each language which indicate if that languages contents are collapsed or opened. For every language except for the first one the symbol is always the same character (minus o plus), the one that was shown when the page was opened. This behaviour is not limited to the history view. --Mikalaari 18:25, 8 September 2006 (CEST)

http://bugzilla.wikimedia.org/show_bug.cgi?id=8096 Siebrand 15:16, 30 November 2006 (CET)
fixed somewhere in time: mediazilla:8096. Malafaya 21:52, 9 October 2009 (UTC)

Clock[edit]

Can someone reset the server clock? It is currently way off. It would also be nice if the default timezone for signatures, etc. were set to UTC. – McDutchie 23:53, 28 April 2009 (EDT)

fixed
I did some changes to the server clock (but I don't remember what exactly). It is now set to UTC and the signatures as well, as far as I can see. Only the recent changes Special:RecentChanges are still displayed in the German timezone (= CET?). --Kipcool 21:17, 9 October 2009 (UTC)
The RC text at the top shows "Server time is now ...." in UTC. The actual time of changes is shown on whatever your preferences for Date/Time is set to. Malafaya 21:20, 9 October 2009 (UTC)

Impossible to try a class[edit]

When I type a few letters to see if a class exists, let's say "com" for "commerce", if I erase them because I got nothing, then I can't get the list of available classes anymore. --Fiable.biz 03:31, 16 September 2009 (UTC)

Yes, typing something does not work. Only the arrows next / previous work. I'll have a look into it. --Kipcool 21:33, 16 September 2009 (UTC)
fixed today. --Kipcool 21:14, 9 October 2009 (UTC)

Time Zone[edit]

In the signatures appears the time as if one is in EST.
In my preferences is written that servertime is UTC.
What's the actual zone we're in?
Patio 06:02, 7 March 2007 (EST)

I agree .. Bugzilla GerardM 03:10, 9 August 2007 (EDT)
how is it now? --Kipcool 21:48, 9 October 2009 (UTC)
assumed fixed. --Kipcool 23:32, 27 November 2009 (UTC)

search not working[edit]

http://www.omegawiki.org/Special:Search?search=%3Apart+of+speech&go=Go

Fatal error: Call to a member function exists() on a non-object in /var/www/ow/includes/SearchEngine.php on line 78

--Purodha Blissenbach 23:35, 20 March 2009 (EDT)

I don't see any error. --Kipcool 21:19, 9 October 2009 (UTC)
Outdated problem. It had to do with the initial colon. Malafaya 21:23, 9 October 2009 (UTC)


No bold text for references to itself[edit]

References to the expression itself used to be bold. Since the recent update this is no longer the case. See for example ozon instead of ozon on Expression:ozon. HenkvD 20:41, 1 June 2006 (CEST)

This is actively being considered. Thanks for posting. GerardM 12:14, 3 June 2006 (CEST)
GerardM, is there any update on this issue? Siebrand 18:34, 18 October 2006 (CEST)
http://bugzilla.wikimedia.org/show_bug.cgi?id=8091 Siebrand 15:09, 30 November 2006 (CET)
Is it an issue? I personally like it better with a link than with bold. --Kipcool 21:31, 9 October 2009 (UTC)


� in Serbian definitions[edit]

Using the Serbian user interface, � is displayed at the end of some Serbian definitions (e.g. Expression:biologija). --Red Baron 11:34, 29 August 2006 (CEST)

It looks fine to me (Firefox) GerardM 13:54, 1 September 2006 (CEST)
it happens to me in French, it's at the end of the part of the def that is displayed (before we click on the "+" sign) when the letter where it's cut is a special character (é, è, ...). (Is it any clear?) Kipcool 19:25, 8 September 2006 (CEST)
Please report if this issue is to be kept open. Siebrand 17:52, 18 October 2006 (CEST)
Seen again today on the above-mentioned article (with Serbian interface). Kipcool 14:47, 17 November 2006 (CET)
http://bugzilla.wikimedia.org/show_bug.cgi?id=8095 Siebrand 15:15, 30 November 2006 (CET)
Still an issue after the Mediawiki update of today Kipcool 09:57, 5 February 2007 (EST)
fixed today. --Kipcool 09:15, 10 October 2009 (UTC)

Chinese interface[edit]

I've just tested the Chinese interface (several: zh, zh-cn, zh-tw, and zh-sg I think), and it looks like one can't add words/definitions in that interface: no language appear in the drop-down boxes. Then, I tried Japanese, this one works fine. Kipcool 15:51, 22 November 2006 (CET)

I think there is no use reporting on interface language issues at the moment because we are over 6 months out of sync with the MediaWiki code. Best wait until we're at SVN HEAD before trying/expecting anything... (unfortunately). Siebrand 17:50, 22 November 2006 (CET)
it's just to keep track and make people aware that Chinese contributors might encounter problems, I don't expect it'll be solved tomorrow. Kipcool 18:06, 22 November 2006 (CET)
This one seems fixed: I see languages in the dropdown although not yet translated. Malafaya 13:58, 10 October 2009 (UTC)

OmegaWiki & KHTML[edit]

OmegaWiki seems to have some scripts (at Edit page, such as this) that may cause KHTML (in Konqueror browser of KDE desktop environment on Linux operating system) to freeze. Is this a bug (that could be fixed)?Trần Thế Trung 11:53, 22 September 2007 (EDT)

When editing an expression/DM, there is some JavaScript code that runs on the browser, namely to sort entries by language name alphabetically. In longer pages, this could give the impression of a freeze for some seconds. This code was somewhat improved in time so you may not notice that pause anymore (I personally don't). Malafaya 15:32, 10 October 2009 (UTC)

Empty language list when user interface is set to lfn (Lingua Franca Nova)[edit]

When I choose lfn (Lingua Franca Nova) as my user language under Special:Preferences, when I try to edit a DM and add a new expression, the language selection box is empty. Changing my user language to another setting returns the normal values for languages. Malafaya 12:49, 9 May 2008 (EDT)

It seems that LFN is no longer among the selectable languages. Malafaya 02:54, 15 February 2009 (CET)
It's back. I guess it was not available in the temporary server only. A hint: there's a blank line between the tabs and the text area when LFN is set as the user interface. Malafaya 11:27, 16 February 2009 (EST)
Hint: LFN works fine in my test system (after applying the same tweaking present here to add it to available languages). Malafaya 11:33, 16 February 2009 (EST)
Apparently fixed after upgrade to MediaWiki trunk. Malafaya 15:45, 10 October 2009 (UTC)

Multiple removals needed when page contains multiple languages[edit]

On several occasions I have noticed that after removing an Expression it still appears in All pages, and most blatantly the link to the page in the deletion log is still blue. Re-removing the page will cause the link to be red. There might be a correlation to the number of Languages represented on the page, all those "sticky" ones I have noticed have been English/English (US) doublets. --Sannab 19:54, 14 August 2006 (CEST)

Reported on bugzilla.wikimedia.org.--Sannab 21:44, 15 August 2006 (CEST)
solved --Kipcool 21:49, 29 November 2009 (UTC)

Russian entry does not show up[edit]

If you click on the Russian entry in DefinedMeaning:forest damage (1536), it leads to Expression:ущерб, нанесенный лесам, but this is an empty, nonexisting page. --Mkill 00:44, 6 March 2007 (EST)

Expression:ущерб, нанесенный лесам is probably deleted, although there is no reference in the deletion log. My Russion is not good but probably it should be Expression:ущерб and/or нанесенный лесам. Just delete ущерб, нанесенный лесам from the DM and replace it by a correct one... HenkvD 14:37, 6 March 2007 (EST)
I did just that. --Kipcool 23:36, 27 November 2009 (UTC)

Error in the database[edit]

I have the following error when I open Expression:kristallisieren, Expression:cristalizar, Expression:kristalliseren, Expression:crystalise:

Une erreur de syntaxe s’est produite lors d’une requête sur la base de données . Cela peut indiquer un bug dans le logiciel. La dernière requête effectuée sur la base de données était :

    SELECT attribute_mid FROM uw_class_attributes WHERE object_id = AND uw_class_attributes.remove_transaction_id IS NULL 

depuis la fonction « ». MySQL a renvoyé l’erreur « 1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND uw_class_attributes.remove_transaction_id IS NULL' at line 1 (localhost) ».

However, there are no errors with Expression:crystallize and the other translations. Any clue? --Kipcool 13:54, 16 March 2009 (EDT)

Similar happens with Expression:harbour --Kipcool 14:10, 16 March 2009 (EDT)
Probably, same problem as reported in #Expression:a. I'll have to download a fresh dump and analyze it. I should find time to do this... Malafaya 11:50, 19 March 2009 (EDT)
The corresponding defined_meaning_id numbers seem to be "379027" and "638795", DefinedMeaning:(379027) DefinedMeaning:(638795). I am not sure how you then obtain the option_attribute number that needs the update. I'd be glad if you tell me :-) --Kipcool 17:22, 19 March 2009 (EDT)
I usually download the latest database dump and analyze the corresponding records. Malafaya 06:16, 20 March 2009 (EDT)
Unfortunately, I get an error while restoring the latest dump:
ERROR 1064 (42000) at line 1689: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''<small>[[User talk:SabineCretella/Archive1|Archive 1]]</small>\n\n== Done! + a ' at line 1. I hope the next one will be fine. Malafaya 12:46, 20 March 2009 (EDT)
Done Done 9 problematic expressions fixed with update uw_option_attribute_values set remove_transaction_id=317785 where option_id=420235;. I'll try to summarise the ad-hoc procedure I used in User:Malafaya/Removed options causing problems. Malafaya 09:09, 29 March 2009 (EDT)
I have corrected this in the php, it should not happen anymore. --Kipcool 21:51, 29 November 2009 (UTC)

Database syntax error[edit]

Cannot open Expression:milliardo. This results in a database error:

Database error
A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:
SELECT attribute_mid FROM uw_class_attributes WHERE object_id = AND uw_class_attributes.remove_transaction_id IS NULL
from within function "". MySQL returned error "1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND uw_class_attributes.remove_transaction_id IS NULL' at line 1 (localhost)".

McDutchie 16:45, 26 April 2009 (EDT)

Hi, Martijn. Nice to see you here :).
This is a known problem. We sometimes find such cases. Take a look at User:Malafaya/Removed options causing problems for more info. I'll look into this when I have some time. Thanks, Malafaya 08:43, 27 April 2009 (EDT)
update uw_option_attribute_values set remove_transaction_id=317785 where option_id=420234;
This fixed 45 expressions. Malafaya 09:16, 27 April 2009 (EDT)
Thanks for the fix and the friendly reply. :) – McDutchie 15:09, 28 April 2009 (EDT)
I have corrected this in the php, it should not happen anymore. --Kipcool 21:52, 29 November 2009 (UTC)

Double log[edit]

When someone resgisters an account, this always shows up twice in the log: Newusers-Log This happens since 21. Jul. 2009 (didn't we have a software update around that time?). Not really a serious problem, but it kinda bugs me. ;-) --Tosca 16:05, 7 December 2009 (UTC)

Probably due to the old "newuserlog" extension, not needed in recent versions of MW. Deactivated. Should be fixed now. Malafaya 16:35, 7 December 2009 (UTC)
Thank you! --Tosca 20:18, 7 December 2009 (UTC)

Not enough place for examples[edit]

The number of characters of the sentences examples seems too limited. I entered a reasonably long sentence with its source for the French expression "d'engagement", but the source got cut off. --Fiable.biz 07:25, 2 September 2009 (UTC)

Seems solved. --Fiable.biz 14:47, 26 November 2012 (CET)

Next year

Meta:Insect room/Archive/2010